import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(abandon)(ar(d?es|em|mos)?)";
final String string = "por abandonar eu\n"
+ "por abandonares tu\n"
+ "por abandonar ele\n"
+ "por abandonarmos nós\n"
+ "por abandonardes vós\n"
+ "por abandonarem eles";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}