package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(abandon)(ar(d?es|em|mos)?)`)
var str = `por abandonar eu
por abandonares tu
por abandonar ele
por abandonarmos nós
por abandonardes vós
por abandonarem eles`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}