#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(abandon)(ar(d?es|em|mos)?)"
Local $sString = "por abandonar eu" & @CRLF & _
"por abandonares tu" & @CRLF & _
"por abandonar ele" & @CRLF & _
"por abandonarmos nós" & @CRLF & _
"por abandonardes vós" & @CRLF & _
"por abandonarem eles"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")