$re = '/(abandon)(ar(d?es|em|mos)?)/m';
$str = 'por abandonar eu
por abandonares tu
por abandonar ele
por abandonarmos nós
por abandonardes vós
por abandonarem eles';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);