import Foundation
let pattern = #"([0-9]{7}[xX0-9]{1})\_([0-9]{3}|[0-9]{3}\-[0-9]{3})\_([0-9]{2}|[0-9]{2}\-[0-9]{2})\_.*\..*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"23526963_013-014_01-03_s001_text.pdf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1_$2_$3"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}