using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{7}[xX0-9]{1})\_([0-9]{3}|[0-9]{3}\-[0-9]{3})\_([0-9]{2}|[0-9]{2}\-[0-9]{2})\_.*\..*";
string substitution = @"$1_$2_$3";
string input = @"23526963_013-014_01-03_s001_text.pdf";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}