const regex = /([0-9]{7}[xX0-9]{1})\_([0-9]{3}|[0-9]{3}\-[0-9]{3})\_([0-9]{2}|[0-9]{2}\-[0-9]{2})\_.*\..*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{7}[xX0-9]{1})\\_([0-9]{3}|[0-9]{3}\\-[0-9]{3})\\_([0-9]{2}|[0-9]{2}\\-[0-9]{2})\\_.*\\..*', '')
const str = `23526963_013-014_01-03_s001_text.pdf`;
const subst = `$1_$2_$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);