// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([0-9]{7}[xX0-9]{1})\_([0-9]{3}|[0-9]{3}\-[0-9]{3})\_([0-9]{2}|[0-9]{2}\-[0-9]{2})\_.*\..*").unwrap();
let string = "23526963_013-014_01-03_s001_text.pdf";
let substitution = "$1_$2_$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}