re = /\/\*.*?\*\//
str = 'adsafsd
asdfs
/*
foo
bar
baz
x */ y
asdf
asdf
zzz
/**
* class Notify
*
* @param int $ts
* @param array $message
*
*/ asdf
class Foobar
{'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end