#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\/\*.*?\*\/"
Local $sString = "adsafsd" & @CRLF & _
"asdfs" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"foo" & @CRLF & _
"bar" & @CRLF & _
" baz" & @CRLF & _
" x */ y" & @CRLF & _
"" & @CRLF & _
"asdf" & @CRLF & _
"asdf" & @CRLF & _
"zzz" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
"* class Notify" & @CRLF & _
"*" & @CRLF & _
"* @param int $ts" & @CRLF & _
"* @param array $message" & @CRLF & _
"*" & @CRLF & _
"*/ asdf" & @CRLF & _
"" & @CRLF & _
"class Foobar" & @CRLF & _
"{"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")