using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*.*?\*\/";
string input = @"adsafsd
asdfs
/*
foo
bar
baz
x */ y
asdf
asdf
zzz
/**
* class Notify
*
* @param int $ts
* @param array $message
*
*/ asdf
class Foobar
{";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}