import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*.*?\\*\\/";
final String string = "adsafsd\n"
+ "asdfs\n\n"
+ "/*\n"
+ "foo\n"
+ "bar\n"
+ " baz\n"
+ " x */ y\n\n"
+ "asdf\n"
+ "asdf\n"
+ "zzz\n\n"
+ "/**\n"
+ "* class Notify\n"
+ "*\n"
+ "* @param int $ts\n"
+ "* @param array $message\n"
+ "*\n"
+ "*/ asdf\n\n"
+ "class Foobar\n"
+ "{";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}