package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\/\*.*?\*\/`)
var str = `adsafsd
asdfs
/*
foo
bar
baz
x */ y
asdf
asdf
zzz
/**
* class Notify
*
* @param int $ts
* @param array $message
*
*/ asdf
class Foobar
{`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}