# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/\*.*?\*\/"
test_str = ("adsafsd\n"
"asdfs\n\n"
"/*\n"
"foo\n"
"bar\n"
" baz\n"
" x */ y\n\n"
"asdf\n"
"asdf\n"
"zzz\n\n"
"/**\n"
"* class Notify\n"
"*\n"
"* @param int $ts\n"
"* @param array $message\n"
"*\n"
"*/ asdf\n\n"
"class Foobar\n"
"{")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.