// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"http(?:s?):\/\/w*\.*wiki\S+").unwrap();
let string = "http://wikipedia.org
http://wiki.mauricio.com
https://wiki.algo.com
https://wikipedia.org
http://www.wikipedia.org
https://
http://www";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}