#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "http(?:s?):\/\/w*\.*wiki\S+"
Local $sString = "http://wikipedia.org" & @CRLF & _
"http://wiki.mauricio.com" & @CRLF & _
"https://wiki.algo.com" & @CRLF & _
"https://wikipedia.org" & @CRLF & _
"http://www.wikipedia.org" & @CRLF & _
"https://" & @CRLF & _
"http://www"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")