re = /http(?:s?):\/\/w*\.*wiki\S+/
str = 'http://wikipedia.org
http://wiki.mauricio.com
https://wiki.algo.com
https://wikipedia.org
http://www.wikipedia.org
https://
http://www'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end