$re = '/http(?:s?):\/\/w*\.*wiki\S+/';
$str = 'http://wikipedia.org
http://wiki.mauricio.com
https://wiki.algo.com
https://wikipedia.org
http://www.wikipedia.org
https://
http://www';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);