package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`http(?:s?):\/\/w*\.*wiki\S+`)
var str = `http://wikipedia.org
http://wiki.mauricio.com
https://wiki.algo.com
https://wikipedia.org
http://www.wikipedia.org
https://
http://www`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}