import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http(?:s?):\\/\\/w*\\.*wiki\\S+";
final String string = "http://wikipedia.org\n"
+ "http://wiki.mauricio.com\n"
+ "https://wiki.algo.com\n"
+ "https://wikipedia.org\n"
+ "http://www.wikipedia.org\n"
+ "https://\n"
+ "http://www";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}