import Foundation
let pattern = #"(amk|amk.|.amk)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
bademeister [amk]
amk
dfusdfhsdoamksdhfg sd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)