$re = '/(amk|amk.|.amk)/';
$str = 'bademeister [amk]
amk
dfusdfhsdoamksdhfg sd';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;