const regex = /(amk|amk.|.amk)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(amk|amk.|.amk)', 'g')
const str = `bademeister [amk]
amk
dfusdfhsdoamksdhfg sd`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);