package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(amk|amk.|.amk)`)
var str = `bademeister [amk]
amk
dfusdfhsdoamksdhfg sd`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}