re = /(amk|amk.|.amk)/
str = 'bademeister [amk]
amk
dfusdfhsdoamksdhfg sd'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result