use strict;
my $str = 'bademeister [amk]
amk
dfusdfhsdoamksdhfg sd';
my $regex = qr/(amk|amk.|.amk)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";