$re = '/(\b10\.5\.(29|31|32)\.15\b|\b10\.0\.100\.75\b)/';
$str = '10.5.31.15
45.36.87.12
10.0.100.75
192.168.1.168
10.5.4.15
10.5.32.15
10.10.25.36
10.0.100.56
10.5.29.15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);