package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b10\.5\.(29|31|32)\.15\b|\b10\.0\.100\.75\b)`)
var str = `10.5.31.15
45.36.87.12
10.0.100.75
192.168.1.168
10.5.4.15
10.5.32.15
10.10.25.36
10.0.100.56
10.5.29.15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}