#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\b10\.5\.(29|31|32)\.15\b|\b10\.0\.100\.75\b)"
Local $sString = "10.5.31.15" & @CRLF & _
"45.36.87.12" & @CRLF & _
"10.0.100.75" & @CRLF & _
"192.168.1.168" & @CRLF & _
"10.5.4.15" & @CRLF & _
"10.5.32.15" & @CRLF & _
"10.10.25.36" & @CRLF & _
"10.0.100.56" & @CRLF & _
"10.5.29.15"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")