const regex = /(\b10\.5\.(29|31|32)\.15\b|\b10\.0\.100\.75\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b10\\.5\\.(29|31|32)\\.15\\b|\\b10\\.0\\.100\\.75\\b)', 'g')
const str = `10.5.31.15
45.36.87.12
10.0.100.75
192.168.1.168
10.5.4.15
10.5.32.15
10.10.25.36
10.0.100.56
10.5.29.15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}