import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b10\\.5\\.(29|31|32)\\.15\\b|\\b10\\.0\\.100\\.75\\b)";
final String string = "10.5.31.15\n"
+ "45.36.87.12\n"
+ "10.0.100.75\n"
+ "192.168.1.168\n"
+ "10.5.4.15\n"
+ "10.5.32.15\n"
+ "10.10.25.36\n"
+ "10.0.100.56\n"
+ "10.5.29.15";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}