$re = '/https?:\/\/[\/\\\\]*(www\.)?/m';
$str = 'https://
http://
https://\\/\\/
https:\\/\\/\\/\\/\\/\\
https://\\/\\/
The reason I include [\\/\\\\]* is because some links like: https://\\/\\/\\/\\/\\/www.google.com actually work.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);