package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/[\/\\]*(www\.)?`)
var str = `https://
http://
https://\/\/
https:\/\/\/\/\/\
https://\/\/
The reason I include [\/\\]* is because some links like: https://\/\/\/\/\/www.google.com actually work.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}