#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https?:\/\/[\/\\]*(www\.)?"
Local $sString = "https://" & @CRLF & _
"http://" & @CRLF & _
"https://\/\/" & @CRLF & _
"https:\/\/\/\/\/\" & @CRLF & _
"https://\/\/" & @CRLF & _
"" & @CRLF & _
"The reason I include [\/\\]* is because some links like: https://\/\/\/\/\/www.google.com actually work."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")