import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/[\\/\\\\]*(www\\.)?";
final String string = "https://\n"
+ "http://\n"
+ "https://\\/\\/\n"
+ "https:\\/\\/\\/\\/\\/\\\n"
+ "https://\\/\\/\n\n"
+ "The reason I include [\\/\\\\]* is because some links like: https://\\/\\/\\/\\/\\/www.google.com actually work.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}