using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/[\/\\]*(www\.)?";
string input = @"https://
http://
https://\/\/
https:\/\/\/\/\/\
https://\/\/
The reason I include [\/\\]* is because some links like: https://\/\/\/\/\/www.google.com actually work.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}