const regex = /https?:\/\/[\/\\]*(www\.)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/[\\\/\\\\]*(www\\.)?', 'gm')
const str = `https://
http://
https://\\/\\/
https:\\/\\/\\/\\/\\/\\
https://\\/\\/
The reason I include [\\/\\\\]* is because some links like: https://\\/\\/\\/\\/\\/www.google.com actually work.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}