// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).+\([\s\S]+?}\);").unwrap();
let string = "test({
test: 1,
time: '11:30am',
color: 'red',
text: '123455};3456'
});
test({
test: 1,
time: '11:30am',
color: 'red',
text: '123455;3456'
});";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}