package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+\([\s\S]+?}\);`)
var str = `test({
test: 1,
time: '11:30am',
color: 'red',
text: '123455};3456'
});
test({
test: 1,
time: '11:30am',
color: 'red',
text: '123455;3456'
});`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}