using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+\([\s\S]+?}\);";
string input = @"test({
test: 1,
time: '11:30am',
color: 'red',
text: '123455};3456'
});
test({
test: 1,
time: '11:30am',
color: 'red',
text: '123455;3456'
});";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}