$re = '/.+\([\s\S]+?}\);/m';
$str = 'test({
test: 1,
time: \'11:30am\',
color: \'red\',
text: \'123455};3456\'
});
test({
test: 1,
time: \'11:30am\',
color: \'red\',
text: \'123455;3456\'
});';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);