import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+\\([\\s\\S]+?\\}\\);";
final String string = "test({\n"
+ " test: 1,\n"
+ " time: '11:30am',\n"
+ " color: 'red',\n"
+ " text: '123455};3456'\n"
+ "});\n\n"
+ "test({\n"
+ " test: 1,\n"
+ " time: '11:30am',\n"
+ " color: 'red',\n"
+ " text: '123455;3456'\n"
+ "});";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}