re = /.+\([\s\S]+?}\);/m
str = 'test({
test: 1,
time: \'11:30am\',
color: \'red\',
text: \'123455};3456\'
});
test({
test: 1,
time: \'11:30am\',
color: \'red\',
text: \'123455;3456\'
});'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end