import Foundation
let pattern = #"{.+}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
Competing Titles {#competing-titles .unnumbered}
================
Why Does He Do That?: Inside the Minds of Angry and Controlling Men {#why-does-he-do-that-inside-the-minds-of-angry-and-controlling-men .unnumbered}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)