const regex = /{.+}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{.+}', 'g')
const str = `Competing Titles {#competing-titles .unnumbered}
================
Why Does He Do That?: Inside the Minds of Angry and Controlling Men {#why-does-he-do-that-inside-the-minds-of-angry-and-controlling-men .unnumbered}`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);