using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{.+}";
string substitution = @"\n";
string input = @"Competing Titles {#competing-titles .unnumbered}
================
Why Does He Do That?: Inside the Minds of Angry and Controlling Men {#why-does-he-do-that-inside-the-minds-of-angry-and-controlling-men .unnumbered}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}