$re = '/{.+}/';
$str = 'Competing Titles {#competing-titles .unnumbered}
================
Why Does He Do That?: Inside the Minds of Angry and Controlling Men {#why-does-he-do-that-inside-the-minds-of-angry-and-controlling-men .unnumbered}';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;