# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{.+}/\n/g;t' <<< "Competing Titles {#competing-titles .unnumbered}
================
Why Does He Do That?: Inside the Minds of Angry and Controlling Men {#why-does-he-do-that-inside-the-minds-of-angry-and-controlling-men .unnumbered}"