re = /^(?:http|ftp)s?:\/\/([\w][^\/=\s]+)\/?|(^w{3}[\.\w][^\/\=\s]{2,})\/?/m
str = 'www.google.com.edu-hjj+oio?/kjhkh.txt hjjh
https://calendar.google.com/calendar/render?tab=ic&pli=1#main_7
http://www.yahoo.comhttp://www.yahoo.co
www.foo.com.ui/=hjg.hhj
ggfhgfhfhf.uui
https://regex101.com/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end