#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:http|ftp)s?:\/\/([\w][^\/=\s]+)\/?|(^w{3}[\.\w][^\/\=\s]{2,})\/?"
Local $sString = "www.google.com.edu-hjj+oio?/kjhkh.txt hjjh" & @CRLF & _
"https://calendar.google.com/calendar/render?tab=ic&pli=1#main_7" & @CRLF & _
"" & @CRLF & _
"http://www.yahoo.comhttp://www.yahoo.co" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"www.foo.com.ui/=hjg.hhj" & @CRLF & _
"ggfhgfhfhf.uui" & @CRLF & _
"https://regex101.com/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")